Account Imports Delayed
Incident Report for AdStage
Resolved
This incident has been resolved.
Posted Jun 07, 2019 - 18:21 PDT
Investigating
We are currently experiencing a delay in imports for all Google Ads accounts and some Facebook accounts. We are investigating the causes of each. Report, Automate, and AdStage for Google Sheets are impacted by these data delays.
Posted Jun 07, 2019 - 11:11 PDT
This incident affected: Ad Management Platform, Import Systems, Automate, and Report.