AdStage Report & Manage - widgets intermittently slow to load
Incident Report for AdStage
Resolved
This incident has been resolved.
Posted 18 days ago. Oct 03, 2019 - 15:18 PDT
Identified
Report and Manage widgets may be slow to load. The issue has been identified and we are working on a fix. We will update you when normal service is restored.
Posted 18 days ago. Oct 03, 2019 - 11:19 PDT
This incident affected: Ad Management Platform and Report.